vSphere 6 Update 1 Appliance installation error

I encountered an issue while deploying a new vSphere 6 Update 1 Appliance. It is not an update, so I was merely deploying a new one. The installation is the same, except that we can now specify a vCenter instead of ESXi as the target deployment.

Everything started well, with the usual mounting of the ISO file into my dedicated Admin Client (a Windows 7 machine). I’ve used the Admin Client for years, so it has everything configured properly. I’ve also deployed and vSphere 6.0 from it, so I know it works.

Then I hit a problem below. It’s a blank error message, so I could not google it.

I tried different combination:

  • Using vCenter or ESXi.
  • Using root or other administrator.
  • Using IP or FQDN.
  • Using different Windows account. I had issue with my roaming profile, which causes my VM to have HA event.

Nothing worked. Still the same error message.

11

Perhaps it’s the ISO. I tried with the vSphere 6.0 (not the U1) as I still have them. It worked!

Then it dawned upon me that maybe it’s the Client Integration Plugin. I had version 6.0, but perhaps it needed version 6 Update 1. So I went to the vcsa folder. Apparently the version has gone up too. I opened the version file and it’s now version 6.0.0.10000 build 3018521

16

I installed the Client Integration plugin. I then launch the installation process again. From the screenshot below, you can see that you can specify vCenter instead.

19

Voila, the installation is happy! In the screenshot below, you can see I’ve passed that Step 2.

20

One more thing. I’m joining into an existing PSC Domain and Site. This could be the reason why it’s not allowing me to specify a different appliance size.

21

After a couple of minutes, it’s all done!

22

Leave a Reply